Create Redis Instance for Nextcloud failed

Bug Report Template


I want to create a redis instance for Nextcloud (Transaction Locking)

I try to follow this instructions:

Steps to Reproduce

Please provide detailed steps to reproduce the bug. Include any necessary code snippets, commands, or configuration files.

  • Run Command

cpcmd -d site3 redis:create nextcloud-cache ‘[unixsocket:/var/www/redis.sock,unixsocketperm:0660]’

  • Step 2
    To check the availability i run the command:

cpcmd -d site3 misc:list-commands ‘redis:*’

  • version

Expected Behavior

Command works like documented

Actual Behavior

got this error message:

apnscpFunctionInterceptor::check_permissions(): command redis_create' does not exist. Did you mean redis_version’?


ApisCP version:

revision: 580c1ea0ec9b485bef8ff7072e0af6005166d48a
timestamp: 1696703086
ver_maj: 3
ver_min: 2
ver_patch: 39
ver_pre: ‘’
dirty: false
debug: false

Operating System:
cat /etc/redhat-release
CentOS Stream release 8

Additional Information:

Run the command for other sites too. All with the same result:


  • version

Without SiteAdmin Context i got this:

cpcmd misc:list-commands ‘redis:*’

  • key_memusage
  • system_info
  • version

Enable SSH service for account and [ssh] => user_daemons in config.ini through Configuration > cp.config as Appliance Administrator.

These methods are revoked if either condition is true.

SSH Service for account was activated, but not user_daemons in config.ini

Enabling user_daemons, fixes my issue.

Maybe a hint in the docs regarding these requirements would be helpfull.


I´ve added a short notice to the documentation.
Here the PR Update by topperharly · Pull Request #140 · thundersquared/apiscp-notes · GitHub