Frontend crashes with site_get_account_quota crash

Frontend Crashes with site_get_account_quota: crash


Unable to access site admin due to frontend crashing.

Steps to Reproduce

  • Setup account as usual
  • Access account using login as or via logging in as the actual user

Expected Behavior

  • Dashboard opens up

Actual Behavior

  • Blank page
  • /usr/local/apnscp/storage/logs/php-fpm.log states "site_get_account_quota": crash or other nasty error detected


ApisCP version: 3.2.38
Operating System: 4.18.0-477.27.1.el8_8.x86_64

Additional Information

This is a different server to the one I was previously having issues with. I just appear to be a magnet for bugs.

Worked it out, something was borked with GRUB.

xfs install without SELinux enabled. Most Alma/Rocky images that I see have SELinux enabled, as this is the default. An automated reboot disarms SELinux, which also deploys the updated kernel boot options that enables user/group/project quotas.

I have had this issue only with OVH dedicated servers.

xfs quota needs to be enabled or you will get a white screen when trying to create an account if quota is not enabled.

I had this on RHEL 8.8 and a fresh install of ApisCP, as OVH don’t have a good iso install system I converted from Alma and Rocky on 2 different servers.

I’m having the same problem with a hetzner cloud server, based on the comments I tried to get SELinux enabled but it appears that is not possible to enable SELinux (at least with the steps that I could find online, check grub config and change SELinux config, and nothing works).
@Snowy What did you do exactly to get it running? Maybe that could help me and others :slight_smile:

Reboot the server. An automated reboot happens if SELinux is disabled, which brings up the kernel with quota support for xfs.

Technical reason is a limitation in utilizing handlers dynamically. Instead of triggering a reboot if xfs parameters change, a reboot is done when SELinux state changes, which happens with most provider images.