[Solved] Failed to download metadata for repo ''timescale_timescaledb''

I have been having trouble on Almalinux 8.

cd /usr/local/apnscp/resources/playbooks;
ansible-playbook bootstrap.yml;

I had a failed install and tried to run the ansible-playbook bootstrap.yml several times. The latest failure is this:

msg: ‘Failed to download metadata for repo ‘‘timescale_timescaledb’’: Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried’

Any ideal?

This error seems to have occured as a result of installing and updating packages before running the apiscp installer.
A reinstall of Almalinux 8 and then minimal instalation of packages and users seems to have worked for me. (Did not run dnf or yum update before running apis installer)

Which steps did you take specifically? An OS package check is applied before installing ApisCP so whether dnf update -y occurred before install is irrelevant as this occurs regardless.

I did not install any other packages this time around.

When I did install packages this is the list I started with.

if [ -x "$(command -v apt)" ]; then
  apt update -y;
  apt upgrade -y;
  apt dist-upgrade -y;
  apt install ipset -y;
  apt install sshpass -y;
  apt install dnsutils -y;
  apt install nano -y;
  apt install memcached -y;
  apt install wget -y;
  apt install unzip -y;
  apt install pwgen -y;
  apt install fail2ban -y;
  apt install nodejs npm -y;
  apt install sudo -y;
  apt install tar -y;
  apt install perl -y;
  apt install php -y;
elif [ -x "$(command -v yum)" ]; then
  yum update -y;
  yum install util-linux-user -y; # chsh
  yum install ipset -y;
  yum install bind-utils -y;
  yum install bind -y;
  yum install epel-release -y;
  yum install python-pip -y;
  yum install sshpass -y;
  yum install nano -y;
  yum install memcached libmemcached -y;
  yum install wget -y;
  yum install unzip -y;
  yum install pwgen -y;
  yum install fail2ban -y;
  yum install nodejs npm -y;
  yum install tar -y;
  yum install perl -y;
  yum install php -y;
  yum install yum-utils -y;
  yum install https://rpms.remirepo.net/enterprise/remi-release-9.2.rpm -y && yum module reset php -y && yum module install php:remi-8.3 -y;
elif [ -x "$(command -v dnf)" ]; then
  dnf makecache --refresh;
  dnf config-manager --set-enabled crb; # enables the crb repository
  dnf update -y;
  dnf install ipset -y;
  dnf install bind-utils -y;
  dnf install util-linux-user -y; # chsh
  dnf install ipset -y;
  dnf install bind-utils -y;
  dnf install bind -y;
  dnf install epel-release -y; # fail2ban and many others
  dnf install python-pip -y;
  dnf install sshpass -y;
  dnf install nano -y;
  dnf install memcached libmemcached -y;
  dnf install wget -y;
  dnf install unzip -y;
  dnf install pwgen -y;
  dnf install fail2ban -y;
  dnf install nodejs npm -y;
  dnf install tar -y;
  dnf install perl -y;
  dnf install yum-utils -y;
  dnf install https://rpms.remirepo.net/enterprise/remi-release-9.2.rpm -y && dnf module reset php -y && dnf module install php:remi-8.3 -y;
  # no op

Overkill. Just run the installer, curl https://raw.githubusercontent.com/apisnetworks/apiscp-bootstrapper/master/bootstrap.sh | bash

Remi PHP can be added afterward but throughput is significantly worse than native builds.

I install multiple distros across multiple providers who provide multiple images. Its not overkill to install packages that i need for other scripts.
Some don’t come with php, some dont come with sshpass, some dont come with wget etc, etc…

It works for me for my purposes.

Remi PHP can be added afterward but throughput is significantly worse than native builds.

Thanks I will look into building from source for systems that dont have a control panel on them.