cp-collect fails to collect: column "service_name" does not exist

I’ve just upgraded to the latest cp-collect version (from commit 43330a3 to commit e8319e) and now I’m getting the following error. There’s no outstanding migration when running .proxy migrate. Could be related to this line: cp-collect/app/Commands/Collect.php#L72.

[root@node1 cp-collect]# sudo -u cpcollect php73 ./proxy collect
 1/4 [▓▓▓▓▓▓▓░░░░░░░░░░░░░░░░░░░░░]  25%
Failed to update records: SQLSTATE[42703]: Undefined column: 7 ERROR:  column "service_name" does not exist
LINE 1: ...) values ($1, $2, $3, $4, $5, $6, $7) on conflict ("domain",...
HINT:  Perhaps you meant to reference the column "domains.server_name" or the column "excluded.server_name". (SQL: insert into "domains" ("addon", "admin_email", "di_invoice", "domain", "server_name", "site_id", "status") values (0, max@mustermann.de, apnscp-L4NGW3IL, mustermann.de, node3, 1, active) on conflict ("domain", "service_name") do update set "site_id" = "excluded"."site_id", "status" = "excluded"."status")

Thanks for the bug report. Fixed upstream.

This is fixed now. Thanks.

How to mark as solved?

Only support topics have the “solved” attribute.