httpd config in management version pre-generated even when webserver_type=null

  • What version of apnscp are you running?
    3.2.42
  • Which version of RHEL or CentOS are you using?
    RockyLinux 8.9
  • Can you reproduce this bug reliably? Provide steps. If not, provide steps to the best of your recollection.

I’ve set webserver_type=null but for some reason there are config files generated at /etc/httpd . They’re always regenerated when I install httpd. How can I set my own config. Is the use of httpd-custom necessarry?

I’m using this command to install the management version but for some reason the /etc/httpd/ folder is managed by apiscp too: curl https://raw.githubusercontent.com/apisnetworks/apiscp-bootstrapper/master/bootstrap.sh | bash -s - -s mariadb_version='10.11' -s system_hostname='sub.domain.com' -s apnscp_admin_email='admin@blackhole.com' -s apnscp_admin_user='administrator' -s panel_headless='true' -s has_dns_only='true' -s webserver_type='null' -s dns_default_provider='null' -s limit_memory_1gb=500 ' '<key>' Installing httpd with my own configuration as reverse proxy is a bit difficult if the config is managed by apiscp.
When I install httpd via dnf, during the install process it says: Executed skriptlet: httpd-2:2.4.59-2.apnscp.x86_64 (and this seems to generate the config files in /etc/httpd/), the same for php-remi.

How can I disable it so that apiscp doesn’t touch the httpd config, also on dnf installations or updates, when I set webserver_type=null.